Siemens Nixdorf PCD-5ND

Update: Da diese Seite hier täglich mehrmals über ,,PCD-5ND“ Suchbegriffe aufgerufen wird, würde mich wirklich mal interessieren weswegen? Schreibt mir doch mal, oder hinterlasst einen Kommentar…

Ich habe dieses Notebook nicht mehr, aber diese Page bleibt zur Dokumentation, falls noch jemand anderes versucht mit dem Notebook was sinnvolles anzufangen. ;)

Ein Forum existiert, wo man noch mehr Hilfe und Antworten zu diesen Notebooks bekommt. Leider existiert das Forum nicht mehr. Ich hatte es an jemand anderen abgegeben, der es dann irgendwann einfach gekillt hat, ohne mir die Chance zur Rücknahme zu geben.

Dies ist meine Geschichte drüber und auch nur eine Installationsanleitung, für Leute, die Linux schon gesehen haben. Es soll die Probleme erläutern, die bei der Installation auftauchen können.

Ich bin durch Zufall auf diese ältere Siemens Nixdorf Notebook Serie gestoßen. Ich suchte ein kleines Notebook, um ein wenig mit Linux unterwegs zu experimentieren. Wirklich erstaunt war ich als ich gesehen habe, was sich die Siemens Techniker damals alles einfallen lassen haben. Dinge, über die sich heute gar keiner mehr Gedanken macht. Wie bekomme ich ein CD-ROM Laufwerk oder gar ein Modem an ein Notebook, wenn möglich unabhängig vom Strom? Eine Variante ist das Notebook Set ASI.

Zuerst versuchte ich die Slackware zu installieren, aber da blieb fast keine Festplattenkapazität mehr übrig. Also begab ich mich auf die Suche und wurde mit VectorLinux 3.2 fündig. Die Installation ist sehr einfach. Man muß sich nur das Basispaket, den Kernel und evtl. ein X11 Paket aus dem Netz laden und ins Verzeichnis /veclinux legen. Dann erzeugt man Root- und Bootdiskette und startet davon. Der Rest sollte halbwegs automatisch ablaufen.

So, nun die Story wie ich es gemacht habe. Ich hatte also noch die 6 Disketten von der Slackware Installation. Ich habe ja auf der Festplatte nur äußerst begrenzten Platz. Also habe ich von den 6 Disketten gebootet, dabei meine Netzwerkkarte eingebunden und war so direkt im Internet. Auf der Festplatte habe ich eine 64MB Partition Typ 82 (Swap) und den Rest als Typ 83 (linux) erzeugt. Die Swappartition nenne ich ab jetzt hda1, die andere hda2. Dann habe ich mit

mkreiserfs /dev/hda2	
mkswap /dev/hda1

das Dateisystem erzeugt und die Swappartition vorbereitet. Aktiviert werden sie mit:

swapon /dev/hda1
mkdir /vec
mount -t reiserfs /dev/hda2 /vec

Damit hat man in /vec die Zielpartition. Dann habe ich die drei Dateien (veclinux.bz2, pentide.bz2 und xf336.bz2) in /veclinux auf diese Partition gelegt – also /vec/veclinux. Leider erkennt das Installationsscript von vectorlinux keine reiserfs Partitionen, also mußte ich den Teil von Hand machen. Aber das ist ganz einfach:

cd /vec
tar xvjpf veclinux/veclinux.bz2
tar xvjpf veclinux/xf336.bz2
tar xvjpf veclinux/pentide.bz2

Damit ist man dann auch schon fast fertig. Man benötigt nur noch eine etc/fstab, die normalerweise mit dem Installationsscript angelegt wird. Die benötigt aber nur wenige Einträge, die man leicht per Hand schreiben kann:

/dev/hda2  /     reiserfs noatime  0 0
/dev/hda1  none  swap     sw       0 0
proc       /proc proc     defaults 0 0

Danach habe ich mit der vectorlinux Startdiskette gestartet, die man sich aus dem Netz laden kann, und lilo eingerichtet. Geht alles herrlich einfach mit dem Konfigurationsprogramm. Dann der Moment – das erste mal Linux von der Platte gebootet. Es geht, aber zwei, drei Dinge habe ich noch angepaßt:

  • in /etc/rc.d/rc.pcmcia PCIC=wasauchimmer auf PCIC=i82365 gestellt – damit geht pcmcia ordentlich
  • in /etc/rc.d/rc.modules APM aktiviert
  • X11 konfiguriert, das geht am besten manuell, zumindest versagt die automatische Erkennung bei mir. Angehangen meine XF86Config (XFree 3.3.6)…
  • mit vasm die Soundkarte konfiguriert – SoundBlaster – ESS1688 bzw ESS688 ging nicht…

Infrarot ist auch sehr einfach, ich habe nur bis auf gnokii noch keine sinnvolle Verwendung gefunden. Einfach die irda-utils saugen, compilen und installieren (am besten mit ‘pkg -n’). Dann in/etc/sysconfig/irda DEVICE auf den eingestellten COM-Port ändern – bei mir ist das COM2, also /dev/ttyS1 – und dann sollte es mit ‘irattach -s’ schon gehen. Testen kann man dann mit ‘irdump’ und einem anderen Infraroten Device…